birtles.org.uk logo

Problem exporting digiguide

Discussion of Version 3 and developing lua grabbers

Problem exporting digiguide

Postby daveyboyc » Mon Dec 13, 2010 1:48 pm

Hi,

Im having trouble grabbing the digiguide. It only seems to export a partial epg from my digiguide. when i run dg2xml from the cmd it gives me "xml skin is missing" over and over again. Can someone perhaps tell me how i can get it to export everything?

Thanks
daveyboyc
 
Posts: 6
Joined: Mon Dec 13, 2010 1:44 pm

Re: Problem exporting digiguide

Postby alanbirtles » Mon Dec 13, 2010 1:56 pm

is there any information in the log?
alanbirtles
Site Admin
 
Posts: 493
Joined: Mon Sep 06, 2004 4:44 pm

Re: Problem exporting digiguide

Postby daveyboyc » Mon Dec 13, 2010 2:16 pm

when i try to run it from the cmd it gives me this:

iewmultichannelgrid?htd=504&dt=<h1>Skin 'xmltv' is missing</viewmultichannelgrid
?htd=504&dt=<h1>Skin 'xmltv' is missing</viewmultichannelgrid?htd=504&dt=<h1>Ski
n 'xmltv' is missing</viewmultichannelgrid?htd=504&dt=<h1>Skin 'xmltv' is missin
g</viewmultichannelgrid?htd=504&dt=<h1>Skin 'xmltv' is missing</h1>&chi=499&noc=
1
daveyboyc
 
Posts: 6
Joined: Mon Dec 13, 2010 1:44 pm

Re: Problem exporting digiguide

Postby alanbirtles » Mon Dec 13, 2010 2:20 pm

I assume you have installed the xmltv skin?
alanbirtles
Site Admin
 
Posts: 493
Joined: Mon Sep 06, 2004 4:44 pm

Re: Problem exporting digiguide

Postby daveyboyc » Mon Dec 13, 2010 2:21 pm

yes ive got that selected in digiguide, but ive renamed it to dg2xml. if i have it as xml it gives me "root error".
daveyboyc
 
Posts: 6
Joined: Mon Dec 13, 2010 1:44 pm

Re: Problem exporting digiguide

Postby daveyboyc » Mon Dec 13, 2010 2:34 pm

any ideas?
daveyboyc
 
Posts: 6
Joined: Mon Dec 13, 2010 1:44 pm

Re: Problem exporting digiguide

Postby alanbirtles » Mon Dec 13, 2010 2:40 pm

the skin has to be called "DG2XML", did you follow the instructions for installing the skin?
alanbirtles
Site Admin
 
Posts: 493
Joined: Mon Sep 06, 2004 4:44 pm

Re: Problem exporting digiguide

Postby daveyboyc » Mon Dec 13, 2010 2:50 pm

well, i followed these instructions somewhat:

ow To Install

1) Run the setup.msi file.
2) Copy the "Digiguide Folder" directory in its entirety into your DigiGuide
install folder.
3) Enable the web service in DigiGuide:
Tools -> Customize -> Web Service -> Enable Web Service
and enter a password.
4) Run DGXMLTV.exe from the command prompt. As a rule the minimum arguments should be:
DGXMLTV -password=yourpassword -outfile="path:\to\where\you\want\the\xmltv\file.xml"

doesnt say to rename it here though, plus i copied it into the server skins folder in digiguide.
daveyboyc
 
Posts: 6
Joined: Mon Dec 13, 2010 1:44 pm

Re: Problem exporting digiguide

Postby daveyboyc » Mon Dec 13, 2010 2:54 pm

is there anything particular i need to be doing?
daveyboyc
 
Posts: 6
Joined: Mon Dec 13, 2010 1:44 pm

Re: Problem exporting digiguide

Postby alanbirtles » Mon Dec 13, 2010 7:46 pm

C:\Program Files\DigiGuide TV Guide\schemes\server skins\DG2XML.dgscheme-web
should contain:
index.html
strings.dat
viewmultichannelgrid.html

if you open http://localhost:2402/skin-DG2XML in your browser you should see a number or a blank page
on the digiguide web service customisation screen if you click the arrow next to "web", "pda" and "tv", one of the listed options should be DG2XML
alanbirtles
Site Admin
 
Posts: 493
Joined: Mon Sep 06, 2004 4:44 pm

Re: Problem exporting digiguide

Postby adriana252 » Thu Sep 29, 2011 11:07 am

personally I only export the channels where I don't get data from MS.
I think I have about 20 channels that I have to set the listings in the setup guide section.
adriana252
 
Posts: 1
Joined: Thu Sep 29, 2011 11:04 am


Return to XMLTV GUI V3

Who is online

Users browsing this forum: No registered users and 1 guest

cron