XMLTVGUI Automated grab Windows 10

Discussion of Version 3 and developing lua grabbers
Post Reply
Posts: 1
Joined: Sat Jul 09, 2016 9:53 pm

XMLTVGUI Automated grab Windows 10

Post by bobtidey » Sat Jul 09, 2016 10:17 pm

I was having problems getting automated grab to work (e.g. NPR UpdateEPG) on a Windows 10 system. I was using Digiguide as the source.

Manually it would run OK and if I issued the same command from a cmd prompt it was also OK.

NPR Log showed it was running UpdateEPG OK but it terminated very quickly and no new guide data was grabbed. Same thing tried to happen if I used Task scheduler.

I found that on Windows 10 the config file was getting saved in the virtual store (C:\Users\username\AppData\Local\VirtualStore\Program Files\XMLTV GUI\settings) rather than in the settings folder under the program files install location. This is windows doing its bit about protecting access to the Program Files folder which nowadays is not supposed to hold application data. When run manually XMLTVGUI was picking up its settings from the same Virtual Store so all was OK. However, when run automatically it was picking up it settings from the original Program Files location and was therefore getting the original default ini file with no grab source defined.

I think work-arounds for this are
1) Manually copy the ini file from the Virtual Store to the physical Program Files settings folder so that the actual config is used in auto mode.

2) Give explicit read/write permissions to the Program Files settings folder. This should mean that changes get stored there rather than in Virtual Store.

3) Install XMLTV GUI in a different directory outside of Program Files so that this protection mechanism doesn't kick in.

To get things going I used method 1, but have now also done 2 so any future config edits should be maintained.

[Thanks for the grabber which is now working very nicely.]

Site Admin
Posts: 495
Joined: Mon Sep 06, 2004 4:44 pm

Re: XMLTVGUI Automated grab Windows 10

Post by alanbirtles » Sun Jul 10, 2016 9:41 am

I assume you are using a scheduled task? Have you set the task to run as you rather than the system user?

Post Reply